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AbstractAbstractAbstract

Building Inflation Tables and CER Libraries
Presenter: James K. Johnson

The ACEIT Librarian is a new tool in ACEIT 7.0 that combines the
Automated Information Manager (AIM) which is used to create 
CERs, and the Inflation Editor which is used to build custom inflation 
indices.  Now users can easily work with Cost Estimating 
Relationship (CER) libraries and Inflation Tables inside a single 
utility.  The Librarian makes it possible for users to have CER 
libraries and Inflation Tables customized for their particular use.  All 
CER libraries and Inflation Tables can then be easily distributed to 
other users.  This session will demonstrate how to Create a Custom 
Inflation Table, Create a Custom Appropriation, Create a New CER
Library, Create a New CER, and Use/Share Custom Libraries.
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Introducing ACEIT LibrarianIntroducing ACEIT LibrarianIntroducing ACEIT Librarian

Efficient: Single utility to manipulate Inflation and 
Methodology Libraries
Productive: Allows for sharing of custom libraries between 
users
Versatile: Provides for customization of all types of libraries

Combination of:
ACEIT Information 
Manager (AIM)

Create CERs

ACEIT Inflation Editor
Create Inflation Indices



Launching the LibrarianLaunching the LibrarianLaunching the Librarian

Start > Programs > ACEIT 7.0 > ACEIT Tools > Librarian
Opens to a main screen for viewing System and Custom 
libraries

Methodology (CER) Libraries
Inflation Libraries



Navigating the LibrarianNavigating the LibrarianNavigating the Librarian
Explorer View

Left hand pane, similar to MS Outlook
Navigate to desired library

Library View
Center pane, displays data in the selected library
Displays information associated with the selected library (Methodology or Inflation) 

Task View
Right pane, quick access to common tasks
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Glossary/DefinitionsGlossary/DefinitionsGlossary/Definitions

Inflation – Measures the change in price from one year to another
Indices – Two Types: Compound and Composite (also called Raw and 
Weighted)

Allow for normalization of costs to a constant year

Raw Inflation Rate - % change in value of money from year 1 to year 2, 
etc.
Outlay Rates (also called Expenditure Profiles) – represent the 
proportion of program dollars that will be spent in each year
Compound (Raw) Indices – Calculated using the Raw inflation rate.  
Used to normalize costs from a particular base year to another year
Composite (Weighted) Indices – Calculated using Compound (Raw) 
indices and outlay rates (expenditure profile).  Used to convert base 
year dollars to then-year (budget) dollars, or to compute funding
requirements



Creating an Inflation IndexCreating an Inflation IndexCreating an Inflation Index

Five Steps to Create an Inflation Index
Step 1: Define the set of goods and services, or overall 
collection of items (Table).  For example, “US Consumer 
Electronics”
Step 2: Define the specific elements (appropriations) within the
collection.  For example, “TV, Stereo, Computer”
Step 3: Collect historical and/or projection pricing data for the 
identified elements
Step 4: Calculate the yearly overall inflation rate for the entire 
collection

Weighted average of the elements

Step 5: Assign a base year, value = 1.0
Results: Compound (Raw) Inflation Indices



Creating a Custom Inflation TableCreating a Custom Inflation TableCreating a Custom Inflation Table
Custom Inflation Tables and/or Appropriations can be added into the Custom 
Library

By default, the Librarian contains one custom inflation table (Sample Table) with one 
appropriation (1234) and its associated indices
You can add new appropriations and their associated indices to the existing table or create a 
new table to store this data
Custom Tables may contain multiple appropriations

Step 1: Navigate to the Inflation Library
Step 2: Click on New Table icon (     ) or select Edit > New Inflation Table
Step 3: Enter table information in the resulting dialog



Creating a New AppropriationCreating a New AppropriationCreating a New Appropriation

Step 1: Navigate to the desired 
custom Inflation Table

Step 2: Click on the New 
Appropriation icon (   ), or select 
Edit > New Appropriation from 
the menu

Step 3: Enter information about 
the indices

Raw/Weighted
Yearly Escalation and Outlay 
rates (Librarian calculates 
resulting raw/weighted indices)



Enter Inflation Indices DirectlyEnter Inflation Indices DirectlyEnter Inflation Indices Directly

Step 4: Enter indices 
manually or paste indices 
from Excel or another 
spreadsheet

White area indicates data 
input.  Grey area indicates 
calculated fields

Step 5: Close the dialog with 
File > Close or red X

The new index is now 
available for use within ACE



Using the Appropriation WizardUsing the Appropriation WizardUsing the Appropriation Wizard

Step 1 Step 2

Step 3 Step 4



Specifying Annual Inflation 
Factors

Specifying Annual Inflation Specifying Annual Inflation 
FactorsFactors

Step 5 – Input
Specify % for each year
Compound (Raw) and Composite 
(Weighted) are calculated for you by 
Librarian based on the specified 
Escalation %
In this example, No weighting 
factors/outlay rates therefore Raw = 
Weighted

Inflation Rate: Inputs and Outputs
Fixed Escalation Increase

Librarian will auto-calculate the 
Compound and Composite values
Can provide Outlay Rates/Expenditure 
profile if needed

Compound (Raw) Indices
No Outlay Rates/Expenditure Profile

Librarian will ask for Compound
Yes Outlay Rates/Expenditure Profile

Librarian will ask for Compound and 
Composite

Yearly Escalation Rates
No Outlay Rates/Expenditure Profile

Librarian will ask for Escalation %
Yes Outlay Rates/Expenditure Profile

Librarian will ask for Escalation % and 
Composite



Specifying Expenditure ProfilesSpecifying Expenditure ProfilesSpecifying Expenditure Profiles

Funds obligated in one 
year will be spent over 
several subsequent years 
(expended)
Expenditure profiles 
represent the percent of 
Total Obligation Authority 
(TOA) expended in any 
particular year

Alternate Step 4



Exporting Inflation IndicesExporting Inflation IndicesExporting Inflation Indices
To facilitate sharing, Inflation Libraries can easily be imported or exported
Export Step 1: Navigate to the custom library
Export Step 2: Select File > Export
Export Step 3: Provide a name for the table.  Custom tables are XML files 
that are put together in a .ZIP file
Export Step 4: Click Save.  By default, the exported library is saved in the 
Libraries directory under ACEIT Data, but the file can be located anywhere

The ZIP file can be e-mailed or placed on a network drive to allow other 
users access



Importing Inflation IndicesImporting Inflation IndicesImporting Inflation Indices
You can quickly import ACEIT 6.1 custom indices or another user’s custom indices 
Import Step 1: Select File > Import
Import Step 2: Select which table to import.  By default it shows all databases that 
are in ACEIT 7.0 format (i.e. ZIP files).  Navigate to a different directory and/or 
change the Files of Type drop down box to look for ACEIT 6.1 databases. (.DB files)
Import Step 3: Select the file to import and click Open
Librarian imports all tables and appropriations from the selected database into your 
custom library

If you have an appropriation that matches one in the import file, you’ll be prompted to 
overwrite or ignore it



Creating  Custom CER 
Libraries

Creating  Custom CER Creating  Custom CER 
LibrariesLibraries



Creating a New Methodology 
Library

Creating a New Methodology Creating a New Methodology 
LibraryLibrary

User can add new CERs to an existing custom library or create a new library
By default, the Librarian contains one custom CER Library (Sample CER Library)

Step 1: Navigate to the Methodology (CER) Library
Step 2: Select File > New > Methodology Library or click Add New 
Methodology Library in tasks section
Step 3:  Enter information about the custom library



Adding a MethodologyAdding a MethodologyAdding a Methodology
Step 1: Navigate to the Methodology (CER) Library and choose the correct CER 
library for the new CER
Step 2: Choose to add or insert a CER using one of these methods:

Click on the Add CER(     ) or Insert CER(     ) icon on the Methodology toolbar
Select Edit > Add CER, Edit > Insert CER, Edit > Insert Child CER from the menu
Select Add CER from the Tasks area

Step 3:  This moves you to the Library View description column to enter the 
information for the CER
Step 4: After entering CER information, enter a CER definition by clicking on Edit 
Definition from the Tasks or by Right-Clicking on the CER in the Library View 



Specifying Standard Methodology 
Variables

Specifying Standard Methodology Specifying Standard Methodology 
VariablesVariables

CERs often contain variables used to estimate a cost, Ex: Antenna cost based on aperture
These variables can be placed in the methodology library so users have specifics on the variable if 

they wish to use the CER
Step 1: Navigate to the Methodology Library
Step 2: Select File > Edit Variables
Step 3: Add, edit, or delete variables in the custom library
Note: For users to see the variable information in ACE when they use the CER, they must 
change their ACE Session Properties so ACE searches parameter libraries for definitions of 
undefined variables encountered.  This check box is found on the Calculation tab inside Session 
Properties (In ACE, Select File > Properties)



Keywords and Custom CERsKeywords and Custom CERsKeywords and Custom CERs
Quickly search for a Custom CER with Keywords

Step 1: Add the Keyword to the CER using the Methodology Keyword List column available in Librarian
Step 2: Select the Keyword from the list available, or create a new keyword with description
Step 3: In Librarian, select File > Save
Step 4: Open ACE 7.0
Step 5: Select Tools > CER Library
Step 6: Search by Subject and select the correct description from the drop down list
Step 8: Select the correct CER from the list at the bottom of the window

Alternately you can change the Destination drop down box to place the methodology in another cell on the active row



Exporting the CER LibraryExporting the CER LibraryExporting the CER Library
To facilitate exchange and sharing, CER Libraries can easily be imported or exported

Export Step 1: Navigate to the custom library
Export Step 2: Select File > Export
Export Step 3: Provide a name for the table.  Custom tables are XML files that are 
put together in a .ZIP file
Export Step 4: Click Save.  By default, the exported library is saved in the Libraries
directory under ACEIT Data, but the file can be located anywhere

The ZIP file can be e-mailed or placed on a network drive to allow other users access



Importing a CER LibraryImporting a CER LibraryImporting a CER Library
Import allows user to bring in ACEIT 6.1 custom methodologies or some other user’s 

custom methodology tables
Import Step 1: Select File > Import
Import Step 2: Select which table to import.  By default it shows all databases that 
are in ACEIT 7.0 format (i.e. ZIP files).  Navigate to a different directory and/or 
change the Files of Type drop down box to look for ACEIT 6.1 databases. (.DB files)
Import Step 3: Select the file to import and click Open
Librarian imports all tables and methodologies from the selected database into your 
custom library

If you have a methodology that matches one in the import file, you’ll be prompted to 
overwrite or ignore it



Using Custom TablesUsing Custom TablesUsing Custom Tables



Using Custom InflationUsing Custom InflationUsing Custom Inflation
Once you have created a custom Inflation 

Table with appropriations, you can use 
them in ACE

Step 1: Open ACE 7.0, Start > 
Programs > ACEIT 7.0 > ACE
Step 2: Select File > Properties and 
switch to Inflation Tab
Step 3: Using the drop down box under 
Custom Inflation Table, select your custom 
table name
The custom inflation indices are now 
available for use in your session.  Using 
either codes or terms in the appropriation 
column you can easily use your custom 
inflation table in an ACE session

The inflation indices used in your 
session are shown in the Session Rates
section of the page
To transfer all indices used in your 
session to your custom database, select 
“Transfer to Custom DB”



Using Custom CERsUsing Custom CERsUsing Custom CERs
Once you have created a custom CER (methodology) 

you can easily use it in ACE 7.0

Step 1: Open ACE 7.0, Start > Programs > ACEIT 
7.0 > ACE
Step 2: Switch to the Methodology window to view 
the Equation/Throughput column
Step 3: Place the cursor on the row you wish to use 
the custom CER
Step 4: Select Tools > CER Library, the CER 
Library dialog opens
Step 5: Make sure the checkbox for “Custom” is 
selected to view the non-system libraries
Step 6: Specify search information to look up the 
specific CER you to wish to use, or simply press 
Search to find all CERs in the selected library
Step 7: Select the desired CER from the list at 
bottom
Step 8: Optional – Click the Definition button (if 
active) to view detailed information about the CER
Step 9: Choose Select and the Methodology will 
automatically be pasted in the active cell you 
selected earlier (Step 3)

Alternately you can change the Destination drop 
down box to place the methodology in another cell 
on the active row



SummarySummarySummary

Building Inflation Table
Creating Appropriation
Building CER Library
Creating CER
Using and Sharing Custom Libraries
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Backup OneBackup OneBackup One

Illustrate an example of data collection, 
calculation of overall inflation rate for 
collection, calculation of raw indices
In general, the equation to calculate the 
index (In) from base year b to year n is In
= (1+Rb+1)*(1+Rb+2)*….*(1+Rn-1)*(1+Rn)

Where Rn is the decimal rate of overall 
inflation for year n.

So to calculate the index for 2008 
from a base year of 2005

we would have I2008= 
(1+R2006)*(1+R2007)*(1+R2008)
From market basket data we know that 
R2006= 2.925% or .02925, R2007=.03, and 
R2008=.0325
So I2008 = (1+ .02925) * (1+.03) * 
(1+.0325)=1.0945816…..

Can be simplified to I2008 = I2007 * 
(1+.0325)=1.0945816



Backup TwoBackup TwoBackup Two
Funding considerations particular to government

Full funding
The total cost of major procurement and construction projects is funded in the fiscal year in 
which they will be initiated

Incremental funding
The total cost of major development programs or projects is funded over two or more fiscal years 
based upon levels and timing of obligation requirements for the funds

Major issue with this policy:  actual expenditures occur for several years past 
the initial obligation
This requires the government to develop a composite index which weights 
the expected expenditures with the anticipated inflation
Out years will have inflation that decreases the purchasing power of money

To maintain purchasing power of money, you must have more money to begin with
Weighted index is ratio of Money Needed / Purchasing Power
The index represents a composite of the out year inflation factors

Weighted by the amount of money spent in each out year according to the expenditure 
profile (outlay rates)

DoD services use two different basic formulas to develop weighted indices
Army uses simple weighting formula
Navy, USMC, Air Force, and Defense Agency use a more complex formula
Librarian can use both, use the drop down box to select
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