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AbstractAbstract

ACEIT includes many features and capabilities that onceACEIT includes many features and capabilities that once 
discovered begin to reveal the real power of ACEIT to the 
user. One such feature is the Dynamic Equation Columns 
(DECs) The discovery of DECs opens new frontiers to the(DECs). The discovery of DECs opens new frontiers to the 
estimator, enhances creativity, increases model efficiency, 
decreases model length and makes navigation easier, and 
decreases errors. This presentation will show an actual 
estimate example that is well suited for multiple uses of 
DECs. It will show the repetitious work and problems p p
involved in building a model in the “pre-DEC discovery” 
period. Then the presentation will take an iterative look at 
the model evolution as DECs are discovered and additionalthe model evolution as DECs are discovered and additional 
DEC opportunities and application are realized and 
implemented.
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Discovering DECs – Estimate Problem Discovering DECs – Estimate Problem 

ABC Support Equipment cables are over 35 years old, 
i t d i k twearing out, and causing work stoppages

Procurement of replacement cables needed 

Develop short turn estimate for ABC Support Equipment 
cable spares, with funding limitations, that can easily and 
quickly run excursions for decision making

Need to buy as many of the cables as possible, at the y y
required quantities, within the available funding. 

If we determine we can’t get all of the cables at the required g q
quantities we have to prioritize and make a determination 
which cables we can get.
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Discovering DECs – Estimate Problem 
(cont) 

Discovering DECs – Estimate Problem 
(cont) (cont) (cont) 

There is limited procurement funding available
Limited design and testing effort to be accomplished 
during FY2010 

Will use existing tech documents and drawings to extent possible
Will use procurement funding

Production effort during FY2011Production effort during FY2011
Finalization during first 7 months of FY2012
Th 127 diff t bl h ith diff tThere are 127 different cables, each with different 
spares quantity requirements
Cost data availableCost data available

Initially - Two catalog systems
Later – Quantity Pricing MatrixQ y g
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Pre-Dec DiscoveryPre-Dec Discovery

What if DECs didn’t exist?
Si ifi tl i t i blSignificantly more input variables            

Significantly more unique IDsSignificantly more unique IDs

Repetitious work and increased equation complexity

Less efficient and increased opportunity for error

Pre-DEC Discovery Cables Spares ACE Sessions
• Prior to Priority LevelPrior to Priority Level
• With Priority Level
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Pre-Dec Discovery ACE SessionsPre-Dec Discovery ACE Sessions

Pre-DEC Discovery Cable Spares Estimate Model (prior 
to priority level) aceitto priority level).aceit

• Multiplies a unique ID for Price and a unique ID for Qty for each of 
127 cables127 cables

• 254 additional input variables and unique IDs

• Number of Cables for calculating design/drawing costs entered as a 
constant
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Pre-Dec Discovery ACE Sessions (cont)Pre-Dec Discovery ACE Sessions (cont)
Pre-DEC Discovery Cable Spares Estimate Model (prior to priority level).aceit
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Pre-Dec Discovery ACE Sessions (cont)Pre-Dec Discovery ACE Sessions (cont)

Pre-DEC Discovery Cable Spares Estimate Model (with 
priority level added) aceitpriority level added).aceit
• We don’t have enough funding to do all cables and associated 

quantities

• We have to prioritize and determine which cables, in order of 
priority, we can get for the available funding

• Requires 127 additional unique IDs for priority of each cable

• Add a priority level input variable to be used to calculate cable priceAdd a priority level input variable to be used to calculate cable price 
of all cables that have a higher priority

• Eliminate “Number of Unique Cables” input variable and use PriorityEliminate Number of Unique Cables  input variable and use Priority 
level to calculate design/drawing costs

• Total additional input variables for Price, Qty, and Priority is 381p , Q y, y 38
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Pre-Dec Discovery ACE Sessions (cont)Pre-Dec Discovery ACE Sessions (cont)
Pre-DEC Discovery Cable Spares Estimate Model (with priority level added).aceit
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The Discovery of DECsThe Discovery of DECs
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What is a DEC?What is a DEC?
Dynamic Equation Columns (DECs) are user-created 
columns used for intermediate inputs or calculations on 
a row
Makes session wider instead of longer
Data stored in DECs should be static

DEC columns evaluate as constants so data stored in DECs 
and equations evaluating in DECs are never time phased
Risk cannot be applied to data in DEC columns
What-if drills cannot be performed on DEC data
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DEC TypesDEC Types
Normal – holds non-cost data and/or equations; excellent for 
marking rows and storing index vectors 
Cost – holds cost data and/or equations.
Comment – holds/stores comments and text that is not 
evaluated or used in ACE calculations (i e model notes)evaluated or used in ACE calculations (i.e. model notes)
Date – holds dates in the form ddMMMyyyy (i.e. Start and Finish 
Date Columns)ate Co u s)
For Normal and Cost DECs you can select to “Sum up results of 
children into their parents for this column”
DEC Type Symbols – separate the column unique ID from the 
column description SYMBOL MEANING

+  Summing Normal DEC 
N S i N l! Non-Summing Normal 
DEC 

$ Summing Cost DEC 
!$ Non-Summing Cost 

DECDEC
*  Comment DEC 
Date Date DEC 
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Adding DECs to Your SessionAdding DECs to Your Session

Each DEC has a general title and an ID name that is used in 
equations to call information from the column
Add New DEC and Edit DEC attributes dialogs

Edit  > Add DEC
Add New DEC icon        on the Session Construction toolbar
Edit > Edit Column Properties

ACE 7.1 Dialog Box
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Referencing DEC DataReferencing DEC Data

To use the values in the DEC columns:To use the values in the DEC columns:

On the current row – enter the DEC name in the 
Equation/Throughput column (e.g. DECID)

On a different row – using dot notation include the 
unique ID of the row being referenced followed by     
a . and the DEC name (e.g. UniqueID.DECID)a  .  and the DEC name (e.g. UniqueID.DECID)
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DEC UsesDEC Uses
Use as an additional Equation/Throughput column
Use when doing a simple total cost estimate that has noUse when doing a simple total cost estimate that has no 
time phasing
Use to store data to use in other equationsq

Simply add DECs for the variables in your CERs
Quantity, Price, learning curve parameters, etc.
Creates a wider session (more columns) instead of a longer session (moreCreates a wider session (more columns) instead of a longer session (more 
rows)

Use with matrix type structures
COEF function; MatVal function; MatColCol; MatColTot; etc.
See Tutorial – Basic Matrix Operations for an example of how to use 
DECs in matrix operationsDECs in matrix operations
You can also view the Example session entitled 98 - Implementing Matrix 
Functions to see how DECs are used with matrix functions
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DEC Uses (cont)DEC Uses (cont)

Use to store information retrieved from 3rd party tools
• Example sessions 05a – MS Project Plug-In, 05b – SEER Plug-In, and 

05c – Price Plug-In show how DECs are used to store information 
retrieved from Microsoft Project, SEER and Pricej ,

Use as an index in functions
Use to store index data to use with the SUMIF function 
Example session 06a – Creating Summary Sections
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Using DECs as Variables or Factors 
to be used in Equations

Using DECs as Variables or Factors 
to be used in Equationsto be used in Equationsto be used in Equations

ACE Session: Cable Estimate with DECs (Qty; Price).aceit
Prior to addition of priority

No Priority – assumes design/drawing required for each cable 

Rather than adding input variables for price and quantity for each of 
127 cables – add a DEC for Qty and a DEC for Price

Eliminates 254 input variables and associated unique IDs

Simply multiply the two DECs together using the same equation onSimply multiply the two DECs together using the same equation on 
each row (Price * Qty)
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Using DECs as Variables or Factors 
to be used in Equations (cont)

Using DECs as Variables or Factors 
to be used in Equations (cont)to be used in Equations (cont)to be used in Equations (cont)

Cable Estimate with DECs (Qty; Price)

Use DECID to Reference on 
Current Row
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Using DECs to store data to use in 
other equations

Using DECs to store data to use in 
other equationsother equationsother equations

ACE Session: Cable Estimate with DECs (Qty; Price; 
Priority; Number Cables) aceitPriority; Number Cables).aceit

Not enough funding for all cables and associated quantities. Must 
prioritize and determine which cables, in order of priority, we can get p p y g
for the available funding
In addition to Price and Qty DECs we add a Priority DEC to be used in 
calculation of Qty and/or total cost for each cable to be procuredcalculation of Qty and/or total cost for each cable to be procured
Eliminates an additional 127 input variables and associated Unique IDs
Add a Number of Cables DEC which can use the Qty DEC or the 
Priority DEC to calculate the number of cables requiring design/ 
drawings
Add an input variable for priority level to be used to determine if anyAdd an input variable for priority level to be used to determine if any 
cost will be calculated for each cable (Use in the Qty DEC; could use in 
the Number Cable DEC and the Equation)
Uses the same equation in the Equation/Throughput column and DECsUses the same equation in the Equation/Throughput column and DECs
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Using DECs to store data to use in 
other equations (cont)

Using DECs to store data to use in 
other equations (cont)other equations (cont)other equations (cont)

Cable Estimate with DECs (Qty; Price; Priority; Number Cables)
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Using DECs to store data to use in 
other equations - UDF

Using DECs to store data to use in 
other equations - UDFother equations UDFother equations UDF

ACE Session: Cable Estimate with DECs and CER UDF.aceit
CThis is a separate model  - uses a CER rather than government catalog 

systems for Price

Developed a log linear CER using 6 specific cables prices obtainedDeveloped a log-linear CER using 6 specific cables prices obtained 
from Contractor A as the independent variable and the corresponding 
prices from the government catalog system as the dependent variable

Used a User Defined Function (UDF) for the CER

The UDF is referenced on each row (same on all rows)

The CER UDF includes the arguments of Price and Qty which are 
contained in the same DECs used in the previous model
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Using DECs to store data to use in 
other equations – UDF (cont)

Using DECs to store data to use in 
other equations – UDF (cont)

Cable Estimate with DECs and CER UDF
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Using DECs with Matrix Type 
Structures 

Using DECs with Matrix Type 
Structures Structures Structures 

MatVal, MatColCol, MatColTot , COEF functions can be 
used similar to the MatDecVal function except they use theused similar to the MatDecVal function except they use the 
FY columns for the matrix rather than unique DEC columns
Example – Matrix Value Function

Mat Val ( @Matri Ro Col )Mat Val ( @Matrix, Row, Col )
@Matrix

This argument is a matrix of x-rows and y-columns. As with all ACE 
matrices, the row address @Matrix is the row preceding the actual matrix 
data and is just a marker for the beginning of the matrix.

Row
This argument is the matrix row where the value is stored. This argument 
can either be a value or a variable, but must be an integer.

Col
This argument is the matrix column where the value is stored. This 
argument can either be a value or a variable, but must be an integer.
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Using Matrix Structures – MatValUsing Matrix Structures – MatVal

ACE Session: Cable Estimate with DECs and Matrix.aceit
This is a separate model - uses quantity pricing matrix rather than 
government catalog system

Contractor A Quantity Pricing Matrix Price based on quantityContractor A Quantity Pricing Matrix – Price based on quantity 
purchased

Used FY columns on Yearly Phasing Workscreen for matrixy g

Each of 127 cables into one of six categories

Added a Category DEC that ties each cable to the Quantity PricingAdded a Category DEC that ties each cable to the Quantity Pricing 
matrix

Use the Matrix Value (MatVal) function in the Price DEC to pull theUse the Matrix Value (MatVal) function in the Price DEC to pull the 
price, based on the quantity of each cable to be purchased, from the 
matrix
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Using Matrix Structures – MatVal (cont)Using Matrix Structures – MatVal (cont)
Quantity Pricing Matrix Stored in FY Columns 

Use Function MatVal to retrieve price from Quantity Pricing Matrix 
based on quantity and category of each cable to be purchased
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Use to store index data (Use with the 
SUMIF function)

Use to store index data (Use with the 
SUMIF function)SUMIF function)SUMIF function)

ACE Session: Cable Estimate with DECs and 
Matrix and SUMIF.aceit

Add Summary Section to summarize cost of each cable 
category

Use SUMIF function with Category DEC to summarize cost 
for each of the 6 cable categoriesfor each of the 6 cable categories

PR-?, 26 January 2010 Approved for Public Release 28



Use to store index data Use to store index data (Use (Use 
with the SUMIF function)with the SUMIF function)

Use to store index data Use to store index data (Use (Use 
with the SUMIF function)with the SUMIF function)

Use the SumIf function to add together desired rows for 

with the SUMIF function)with the SUMIF function)with the SUMIF function)with the SUMIF function)

Summary Sections
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Viewing DEC Results Viewing DEC Results 

Methodology Reports show DEC results
Go to the Reports Menu and set the Report Type to Methodologyp p yp gy
Each DEC Reported with two columns: Equation and Result

New ACEIT 7 2 DEC Reports

DEC Equation DEC Result

New ACEIT 7.2 DEC Reports
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New ACE 7.2 DEC FeaturesNew ACE 7.2 DEC Features

DEC Results can be viewed in the Inputs/Results 
Viewer (IRV)

N ti l DEC D i ti fi ld t th Add NNew optional DEC Description field to the Add New 
DEC and Edit DEC attributes dialogs (Edit > Add DEC)

New DEC Reports shows DEC column results
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DEC Results can be viewed in the IRVDEC Results can be viewed in the IRV

Select DECs dialog
Allows you to select which DEC columns to view in theAllows you to select which DEC columns to view in the 
Inputs/Results Viewer (IRV)
Opens when you have selected to View > BY DEC Results  from 
within the Inputs/Results Viewer and you select View > Selectwithin the Inputs/Results Viewer and you select  View > Select 
DECs from the menu
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DEC Results can be viewed in the IRV 
(cont)

DEC Results can be viewed in the IRV 
(cont)(cont)(cont)
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New optional DEC Description fieldNew optional DEC Description field

Found in the Add New DEC and Edit DEC attributes dialogsFound in the Add New DEC and Edit DEC attributes dialogs
Edit  > Add DEC
Edit > Edit Column Properties

New Description Field

ACE 7.2 Dialog Box
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New POST DEC Reports New POST DEC Reports 

POST > Reports > New > DEC 
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New POST DEC Reports (cont)New POST DEC Reports (cont)

POST DEC Report shows DEC column results
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SummarySummary

Exploring and learning the capabilities and features of 
ACEIT, such as DECs, will lead to the discovery of untapped , , y pp
power of ACEIT. 
DEC Uses Explored:

Use to store and/or calculate data (quantity; price; priority; number of 
cables) to use in other equations, including UDFs
Use with matrix type structures (MatDecVal; MatVal)
Use as an index in functions (SumIF)

Data stored in DECs should be static
C fDECs reduce the number of input variables, eliminate 

repetitious work, simplifies equations, increase efficiency, 
and decreases error
View DEC Results in Methodology Report, ACEIT 7.2 POST 
DEC Report, and ACEIT 7.2 IRV
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Backup SlidesBackup Slides
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DEC Uses – Start Date and 
Fi i h D t

DEC Uses – Start Date and 
Fi i h D tFinish DateFinish Date

Start Date and Finish Date columns behave much like a DEC --Start Date and Finish Date columns behave much like a DEC --
reported as a DEC -- but you cannot rename or delete the 
column. 

Equations on the same row may access the Start Date and Finish Date 
results using the following IDs: aStartDate and aFinishDate.
Equations on other rows may access the Start Date and Finish Date resultsEquations on other rows may access the Start Date and Finish Date results 
using dot notation to include the unique ID of the row being referenced 
followed by the “ . “ and the DEC name aStartDate and aFinishDate (e.g. 
UniqueID aStartDate)UniqueID.aStartDate).

This is useful because you can have schedule-like equations that link time 
phasing from one row to another. (UniqueID.afinishdate+30)
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Using DECs with Matrix Type 
Structures (As Lookup Functions)

Using DECs with Matrix Type 
Structures (As Lookup Functions)Structures (As Lookup Functions)Structures (As Lookup Functions)

Matrix DEC Value function allows you to easily retrieve data 
f DEC lfrom a DEC column

Similar to the MatVal function except that it requires a DEC ID 
instead of a year index to access the result.

MatDecVal ( @Matrix, Index, @DECId )
@Matrix
Thi t i th dd f t bl f l d i ACE likThis argument is the row address of a table of values used in ACE like a 

matrix. The elements of the matrix are always indented one level more 
than the row with the unique ID.

Index
This argument is the number of rows down the matrix to access. It should be 

a number between 1 and the last row in the matrix.
@DECId

f C fThis argument refers to the DEC column where the value is located for row 
Index. The "@" tells ACE to pass in a column address. 
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Using DECs as Lookup Functions 
Example

Using DECs as Lookup Functions 
ExampleExampleExample

Aircraft Equipment weights are stored in a DEC
Average Cost/Pound is a variable

Some weights are 
factors of the 
Airframe Weight

The Equipment Cost can be calculated easily using the DEC

g

Same Equation goes 
on all rows
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Using DECs as Lookup Functions 
Example (cont)

Using DECs as Lookup Functions 
Example (cont)Example (cont)Example (cont)

Use Function MatDECVal to retrieve weight data and multiply it 
by the average cost/pound on a different rowby the average cost/pound on a different row
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